Обзор forticlient endpoint security suite

Sample configuration

WAN interface is the interface connected to ISP. This example shows static mode. You can also use DHCP or PPPoE mode. The SSL VPN connection is established over the WAN interface.

To configure SSL VPN using the GUI:
  1. Configure the interface and firewall address. The port1 interface connects to the internal network.
    1. Go to Network > Interfaces and edit the wan1 interface.
    2. Set IP/Network Mask to 172.20.120.123/255.255.255.0.
    3. Edit port1 interface and set IP/Network Mask to 192.168.1.99/255.255.255.0.
    4. Click OK.
    5. Go to Firewall & Objects > Address and create address for internet subnet 192.168.1.0.
  2. Configure user and user group.
    1. Go to User & Device > User Definition to create a local user sslvpnuser1.
    2. Go to User & Device > User Groups to create a group sslvpngroup with the member sslvpnuser1.
  3. Configure SSL VPN web portal.
    1. Go to VPN > SSL-VPN Portals to create a tunnel mode only portal my-split-tunnel-portal.
    2. Enable Split Tunneling.
    3. Select Routing Address.
  4. Configure SSL VPN settings.
    1. Go to VPN > SSL-VPN Settings.
    2. For Listen on Interface(s), select wan1.
    3. Set Listen on Port to 10443.
    4. Choose a certificate for Server Certificate. The default is Fortinet_Factory.
    5. In Authentication/Portal Mapping All Other Users/Groups, set the Portal to tunnel-access.
    6. Create new Authentication/Portal Mapping for group sslvpngroup mapping portal my-split-tunnel-portal.
  5. Configure SSL VPN firewall policy.
    1. Go to Policy & Objects > IPv4 Policy.
    2. Fill in the firewall policy name. In this example, sslvpn split tunnel access.
    3. Incoming interface must be SSL-VPN tunnel interface(ssl.root).
    4. Choose an Outgoing Interface. In this example, port1.
    5. Set the Source to all and group to sslvpngroup.
    6. In this example, the Destination is all.
    7. Set Schedule to always, Service to ALL, and Action to Accept.
    8. Click OK.
To configure SSL VPN using the CLI:
  1. Configure the interface and firewall address.
    config system interface 
        edit "wan1"
            set vdom "root"
            set ip 172.20.120.123 255.255.255.0
        next
    end
  2. Configure internal interface and protected subnet, then connect the port1 interface to the internal network.
    config system interface
        edit "port1"
            set vdom "root"
            set ip 192.168.1.99 255.255.255.0
        next
    end
    config firewall address
        edit "192.168.1.0"
            set subnet 192.168.1.0 255.255.255.0
        next
    end
  3. Configure user and user group.
    config user local
        edit "sslvpnuser1" 
            set type password
            set passwd your-password
        next 
    end
    config user group
        edit "sslvpngroup" 
            set member "vpnuser1"
        next 
    end
  4. Configure SSL VPN web portal.
    config vpn ssl web portal
        edit "my-split-tunnel-portal"
            set tunnel-mode enable
            set split-tunneling  enable
            set split-tunneling-routing-address "192.168.1.0"
            set ip-pools "SSLVPN_TUNNEL_ADDR1"
        next
    end
  5. Configure SSL VPN settings.
    config vpn ssl settings
        set servercert "Fortinet_Factory"
        set tunnel-ip-pools "SSLVPN_TUNNEL_ADDR1"
        set tunnel-ipv6-pools "SSLVPN_TUNNEL_IPv6_ADDR1"
        set source-interface "wan1"
        set source-address "all"
        set source-address6 "all"
        set default-portal "full-access"
        config authentication-rule
            edit 1
                set groups "sslvpngroup"
                set portal "my-split-tunnel-portal" 
            next        
    end
  6. Configure one SSL VPN firewall policy to allow remote user to access the internal network. Traffic is dropped from internal to remote client.
    config firewall policy 
        edit 1
            set name "sslvpn web mode access"
            set srcintf "ssl.root"
            set dstintf "port1"
            set srcaddr "all"
            set dstaddr "192.168.1.0"
            set groups “sslvpngroup”
            set action accept
            set schedule "always"
            set service "ALL"
        next
    end
To see the results:
  1. Download FortiClient from www.forticlient.com.
  2. Open the FortiClient Console and go to Remote Access.
  3. Add a new connection.
    • Set VPN Type to SSL VPN.
    • Set Remote Gateway to the IP of the listening FortiGate interface, in this example, 172.20.120.123.
  4. Select Customize Port and set it to 10443.
  5. Save your settings.
  6. Use the credentials you’ve set up to connect to the SSL VPN tunnel.
  7. After connection, traffic to 192.168.1.0 goes through the tunnel. Other traffic goes through the local gateway.
  8. In FGT, go to VPN > Monitor > SSL-VPN Monitor to verify the list of SSL users.
  9. In FGT, go to Log & Report > Traffic Log > Forward Traffic and view the details for the SSL entry.

Installing FortiClient (Linux)

You can install FortiClient (Linux) on the following operating systems:

  • Red Hat
  • CentOS
  • Ubuntu

For supported versions, see Product Integration and Support.

To install a FortiClient (Linux) 6.0.4 RPM package, you must first uninstall any earlier version of FortiClient (Linux) installed. It is not supported to upgrade to FortiClient (Linux) 6.0.4 using the RPM package.

Installing FortiClient (Linux) from repo.fortinet.com

You can install FortiClient (Linux) from the repository at repo.fortinet.com.

Installing on Red Hat or CentOS

  1. Add the repository by using the following command:

    sudo yum-config-manager —add-repo http://repo.fortinet.com/repo/centos/7/os/x86_64/fortinet.repo

  2. Install FortiClient by using the following command:

    sudo yum install forticlient

Installing on Ubuntu

  1. Install the gpg key by using the following command:

    wget -O — http://repo.fortinet.com/repo/ubuntu/DEB-GPG-KEY | sudo apt-key add —

  2. Do one of the following:
    1. If installing on Ubuntu 16.04 LTS, add the following line in :

      deb http://repo.fortinet.com/repo/ubuntu/ xenial multiverse

    2. If installing on Ubuntu 18.04 LTS, add the following line in :

      deb http://repo.fortinet.com/repo/ubuntu/ bionic multiverse

  3. Update package lists by using the following command:

    sudo apt-get update

  4. Install FortiClient by using the following command:

    sudo apt install forticlient

Installing FortiClient (Linux) using a downloaded installation file

Installing on Red Hat or CentOS

  1. Obtain a FortiClient Linux installation rpm file.
  2. In a terminal window, run the following command:

    $ sudo yum install <FortiClient installation rpm file> -y

    is the full path to the downloaded rpm file.

Installing on Ubuntu

  1. Obtain a FortiClient Linux installation deb file.
  2. Install FortiClient using the following command:

    $ sudo apt-get install <FortiClient installation deb file>

    is the full path to the downloaded deb file.

Installation folder and running processes

FortiClient installation folder is .

is in

In case there are issues, or to report a bug, FortiClient logs are available in .

Some running processes include:

  • fctsched
  • fortitray
  • FortiClient
  • epctrl

Безопасное беспроводное подключение через FortiAP

Перед основной настройкой доступа сотрудников с удалённых рабочих мест с помощью FortiAP необходимо настроить соответствующие разрешения на межсетевом экране FortiGate.

На внешнем интерфейсе FortiGate, с которым будет связываться FortiAP, следует разрешить подключение к Fortinet Security Fabric (для устройств под управлением FortiOS 6.2.3 или выше) либо использование CAPWAP — туннельного протокола, применяемого для взаимодействия между точками беспроводного доступа и контроллером (в нашем случае это FortiGate). Второй вариант предназначен для устройств под управлением операционной системы FortiOS 6.2.2 или ниже.

Рисунок 18. Разрешение подключения FortiAP к корпоративной сети через FortiGate

 

Для сотрудников, работающих удалённо, создаётся отдельный профиль FortiAP для применения раздельного туннелирования и шифрования к устройствам в этом профиле.

Рисунок 19. Параметры профиля FortiAP

 

Для SSID, который применяется для созданного профиля FortiAP, необходимо разрешить разделённое туннелирование.

Рисунок 20. SSID для FortiAP

 

Настройка FortiAP может осуществляться с использованием облачного решения FortiAP Cloud, которое оснащено функциями по управлению автономными точками доступа FortiAP. FortiAP Cloud поддерживает выделение ресурсов, мониторинг, устранение неполадок и оптимизацию развёртывания оборудования FortiAP. Лицензионный ключ FortiAP Cloud входит в комплект поставки каждой точки доступа FortiAP, за счёт чего администратор может оперативно развернуть последние.

Рисунок 21. Контролируемые точки доступа FortiAP в интерфейсе администратора FortiAP Cloud

 

Рисунок 22. Подробная информация о точке доступа FortiAP

 

В интерфейсе администратора FortiGate также приводится информация о подключённых точках беспроводного доступа FortiAP.

Рисунок 23. Подключённые точки доступа FortiAP в интерфейсе администратора FortiGate

 

Рисунок 24. Детальная информация о точке доступа FortiAP

 

Описание редакции

скачать

Сравнение альтернативных программ:

SpyKing Email Spy 2010

Audio Watermarking Tools 2 (AWT2)

SpyKing Yahoo! Messenger Spy 2012

Pro-Key-Lock

Описание Тайно отслеживайте все электронные письма Скачать Audio Watermarking Tools 2 (AWT2), версия 0.13.00 Тайно фиксируйте все входящие и исходящие сообщения Yahoo Скачать Pro-Key-Lock, версия 3.3.0
Рейтингу
Загрузки 180 55 43 157
Цена $ 49.99 $ 90 $ 49.99 $ 19.35
Размер файла 4.00 MB 4.77 MB 3.00 MB 1.19 MB

Download

Download

Download

Download

Пользователи, которые скачивали FortiClient, также скачивали:

Мы рады посоветовать вам программы которые понравились другим пользователям FortiClient. Вот список программ, аналогичных FortiClient:

Camera Card Recovery Software 
3.0.1.5

Восстановите поврежденные и утерянные фото и видео

скачать
Резервирование и восстановление

Рейтинг пользователей

Camera Card Recovery 
3.0.1.5

Восстановите удаленные фотографии с вашего цифрового фотоаппарата

скачать
Резервирование и восстановление

Рейтинг пользователей

Repair NTFS File System 
4.0.1.6

Восстановите файлы, которые вы считали утерянными.

скачать
Резервирование и восстановление

Рейтинг пользователей

Recover iPod Missing Files 
4.0.1.6

Восстанавливайте удаленные файлы с вашего iPod

скачать
Резервирование и восстановление

Рейтинг пользователей

Protect your connections with this free program

FortiClient is a free security program that enables you to heighten your endpoint protection. Developed by Fortinet, this software acts as an integrated platform with automated next-generation features on threat protection and visibility. It allows you to control your whole security system and easily keep an eye on suspicious activity that may attack weak links in your networks. Using this program can prevent your phones, tablets, computers, and other connected devices from being exploited.

Connections can be vulnerable

By its simplest definition, endpoint protection is the approach to the protection of computer networks that are remotely bridged to client devices. This means that the connection of laptops, tablets, mobile phones, and other wireless devices to corporate networks are usually vulnerability points for security threats. To protect these areas, you’d need a proper program dedicated to such a task. FortiClient is one such software and offers reliable features that you can take advantage of. integrates endpoints into Fortinet Security Fabric

FortiClient contains three key modules: Fabric Agent for security Fabric connectivity, the endpoint security modules, and the secure remote access modules. The program integrates endpoints into the Fortinet Security Fabric platform, which allows for early detection and advanced threat prevention. Thus, any activity will be reported in real-time, such as malware and botnet detections. You can also set policies to automatically quarantine suspicious or compromised endpoints and investigate them. There are automated processes in FortiAnalyzer that can help with this.

Advanced features to help you

The Vulnerability Management feature, on the other hand, aids in detecting any operating system and third-party application vulnerabilities in real-time. It enables you to reduce the endpoint attack surface and manage endpoint-borne risks by scanning and patching these issues. If you want additional information on the current threats, you can connect to FortiSandbox Cloud. It has a behavior-based analysis process that applies to all downloaded files through the endpoints you have and it will check if you’re up-to-date with the latest online threats.

This software also provides secure remote access with its built-in VPN, single-sign-on, and two-factor authentication for added security. It aims to be easy to use with its interface and will display all relevant information in such a simple way for any type of user. However, you may find some issues with installing updates from time to time. This security program has two licensing modes: the free Standalone mode and the licensed Managed mode that features FortiGate and FortiClient Enterprise Management Server for your use.

A steady software all in all

Overall, FortiClient’s automated features make it easy to set up and use, and it acts as a complete security package for anyone. There are still some drawbacks to be found but this software is still highly recommended—especially since it notably passed the NSS Labs’ 2019 Advanced Endpoint Test with the “Recommended” rating.

FortiClient EMS and FortiGate Endpoint Licenses

SECURITY FABRIC AGENT
PROVISIONING
Centralized Client Provisioning
Client Software Updates
Windows AD Integration
FortiTelemetry Gateway IP List
Software Inventory Management
Automatic Group Assignment
COMPLIANCE ENFORCEMENT AND SECURITY FABRIC INTEGRATION
Fortinet Security Fabric Integration
Security Posture Check
Vulnerability Compliance Check
Dynamic Access Control
Authorized Device Detection
Automated Endpoint Quarantine
REMOTE CONTROL
On-demand Antivirus Scan
On-demand Vulnerability Scan
Host Quarantine
TELEMETRY AND MONITORING
Client Information (client version, OS IP/MAC
address, profile assigned, user avatar)
Client Status
Reporting (To FortiAnalzyer)

PLUS — Add Sandbox Cloud Subscription for Proactive Advanced Threat Detection

Compatibility Windows Mac OS X Android iOS ChromeBook Linux
SECURITY FABRIC COMPONENTS
Endpoint Telemetry1
Compliance Enforcement using Dynamic Access Control1
Endpoint Audit and Remediation
with Vulnerability Scanning1
Automated Endpoint Quarantine
HOST SECURITY AND VPN COMPONENTS
Antivirus
Cloud-based Threat Detection
Anti-Exploit
Sandbox Detection (on-prem) (Limited *)
Sandbox Cloud Detection
Web Filtering2
Application Firewall1
IPSec VPN
SSL VPN3
OTHERS
Remote Logging and Reporting4
Windows AD SSO Agent
USB Device Control

PLUS — Add Sandbox Cloud Subscription for Proactive Advanced Threat Detection

1 Requires FortiClient to be managed by EMS 2 Also compatible in Chrome OS 3 Also compatible in Linux and Windows Mobile.
The list above is based on the latest OS for each platform.4 Requires FortiAnalyzer * No file Submission

Download datasheet
View documentation

Installation options

When the administrator creates a FortiClient deployment package in EMS, they choose which setup type and modules to install:

  • Secure Remote Access: VPN components (IPsec and SSL) are installed.
  • Advanced Persistent Threat (APT) Components: FortiSandbox detection and quarantine features are installed.
  • Additional Security Features: One or more of the following features are installed: AV, Web Filtering, Single Sign On, and Application Firewall.

It is recommended to not install VPN components on Windows Server systems if not required.

The FortiClient (Windows) installer is available on EMS. You can configure and select installed features and options on EMS.

Firmware images and tools

The following files are available from the Fortinet support site:

File

Description

FortiClientTools_6.2.1.xxxx.zip

Zip package containing miscellaneous tools, including VPN automation files.

FortiClientSSOSetup_6.2.1.xxxx.zip

FortiClient Single Sign On (FSSO)-only installer (32-bit).

FortiClientSSOSetup_6.2.1.xxxx_x64.zip

FSSO-only installer (64-bit).

The FortiClient (Windows) 6.2.1 standard installer and zip package containing FortiClient.msi and language transforms are included with FortiClient EMS 6.2.1.

The following tools and files are available in the FortiClientTools_6.2.xx.xxxx.zip file:

File

Description

FortiClientVirusCleaner

Virus cleaner.

SSLVPNcmdline

Command line SSL VPN client.

SupportUtils

Includes diagnostic, uninstallation, and reinstallation tools.

VPNAutomation

VPN automation tool.

The following file is available from FortiClient.com:

File

Description

FortiClientVPNOnlineInstaller_6.2.exe

Free VPN-only installer. This VPN-only client does not include Fortinet technical support.

Review the following sections prior to installing FortiClient version 6.2.1: Introduction, Special notices, and Product integration and support.

Сценарии работы пользователей в концепции Fortinet Security Fabric

Fortinet предусмотрела разграничение прав пользователей, разделив их на 3 категории: обычные пользователи, опытные пользователи, суперпользователи.

Обычный пользователь

Обычный пользователь — рядовой сотрудник компании, который для выполнения своих профессиональных обязанностей использует электронную почту, интернет, сетевые хранилища.

Доступ в корпоративную сеть осуществляется по VPN через FortiClient. Этот продукт обеспечивает защиту терминалов и предоставляет широкий спектр механизмов безопасности:

  • карантин конечных точек,
  • расширенную защиту от сложных угроз,
  • защиту от вредоносных программ и эксплойтов,
  • обеспечение соответствия требованиям (compliance),
  • обнаружение угроз, использующих облачные сервисы,
  • выявление и исправление уязвимостей,
  • взаимодействие с сетевой песочницей FortiSandbox,
  • веб-фильтрацию,
  • межсетевой экран приложений,
  • поддержку IPSec VPN и SSL VPN,
  • взаимодействие с FortiGuard и автоматическое получение обновлений безопасности,
  • контроль USB-устройств и установленных приложений.

FortiClient поддерживает все популярные операционные системы, в том числе и мобильные.

Рисунок 1. Сценарий работы обычного пользователя через FortiClient

 

Пользователь проходит многофакторную аутентификацию с помощью FortiToken.

В случае угрозы безопасности корпоративной сети со стороны удалённого работника администратор может изолировать его рабочее место, поместив его на карантин, через FortiClient с помощью сервера Enterprise Management Server (FortiClient EMS).

FortiClient EMS обеспечивает видимость всей сети для безопасного обмена информацией и назначения профилей безопасности для конечных точек, находящихся под защитой FortiClient. Сервер включает в себя автоматизированные механизмы управления устройствами и устранения неполадок. FortiClient EMS также работает с расширением FortiClient Web Filter для обеспечения веб-фильтрации на устройствах Google Chromebook.

Опытный пользователь

Опытный пользователь — сотрудник компании, который для выполнения своих обязанностей использует более широкий доступ к корпоративным ресурсам, нежели его «обычный» коллега. Как правило, опытные пользователи работают в нескольких ИТ-средах. Это могут быть системные администраторы и специалисты технической поддержки.

Для таких сотрудников Fortinet предлагает развернуть точку доступа FortiAP на удалённом рабочем месте, обеспечивая возможность связываться с корпоративной сетью по защищённому туннелю. FortiAP подключается к межсетевому экрану следующего поколения FortiGate, стоящему на границе корпоративной сети. При необходимости к FortiAP можно подключить корпоративный телефон для связи с главным офисом. Дополнительно пользователю предоставляется раздельное туннелирование для облачных или SaaS-приложений с прямым интернет-соединением.

Рисунок 2. Сценарий работы опытного пользователя через FortiAP

 

Суперпользователь

Суперпользователь — сотрудник компании, которому должен быть предоставлен доступ к конфиденциальным данным и ресурсам в любой момент времени. Такие сотрудники обрабатывают информацию с высоким уровнем значимости для компании. Это могут быть привилегированные администраторы, специалисты технической поддержки, высшее руководство, ключевые партнёры.

Для таких пользователей Fortinet предлагает настраивать полноценное рабочее место с расширением функций безопасности за счёт интеграции с FortiGate или FortiWiFi для безопасного беспроводного соединения со встроенной защитой от потери данных. Для телефонных переговоров суперпользователю предлагается использовать устройства VoIP-телефонии FortiFone или программный клиент.

Рисунок 3. Сценарий работы суперпользователя через FortiGate / FortiWiFi

 

Далее рассмотрим настройку двух вариантов подключения удалённых пользователей.

Фунциональные возможности FortiClient Endpoint Security Suite

FortiClient Endpoint Security Suite – продукт класса Internet Security, который призван обеспечить всестороннюю защиту конечных точек корпоративной сети от различных видов угроз. Для решения этой задачи в нем реализованы следующие функциональные возможности.

Защита от вредоносных программ

Компания Fortinet является разработчиком собственного антивирусного ядра. Антивирусная защита обеспечивается работой антивирусного монитора. При необходимости, можно осуществлять проверку жесткого диска по расписанию. Для определения вредоносных объектов используются как база данных сигнатур, так и эвристический анализ.

FortiClient Endpoint Security Suite также обеспечивает антивирусную проверку почтового трафика по протоколам POP3 и SMTP. Помимо сигнатурного детектирования в программе есть эвристический анализ и функция определения интернет-червей.

В программе существует карантин, в который помещаются все подозрительные объекты (если в настройках антивируса указано перемещать обнаруженные объекты в карантин). Пользователь может в любой момент просмотреть их, отправить разработчикам для тестирования, сообщить о ложном срабатывании или же добавить данный файл и/или папку в исключения из проверки их антивирусом.

Персональный файрвол

В FortiClient Endpoint Security Suite реализован персональный файрвол, предназначенный для обеспечения защиты компьютера от сетевых атак и несанкционированных подключений. Интересной его особенностью является возможность создания произвольного количества сетевых зон и их подразделение на несколько типов с отдельными правилами для каждого типа. В состав файрволла  также входит система обнаружения вторжений (IPS), способная детектировать и блокировать сетевые атаки.

VPN-клиент

Одной из ключевых особенностей рассматриваемого продукта является наличие VPN-клиента. С его помощью можно подключаться к корпоративным сервисам с использованием технологий IPSec и SSL.

Фильтрация веб-контента

В FortiClient Endpoint Security Suite существует возможность фильтрации веб-контента по категориям. Справедливости ради стоит отметить, что эффективность этой функции для русскоязычных сайтов требует дополнительного тестирования.

Антиспам

В рассматриваемой программе реализована система блокирования спама. В отличие от традиционного байесовского фильтра, она не требует никакой настройки. Дело в том, что представленный антиспам работает на основе подготавливаемых разработчиками правил, которые регулярно обновляются.

WAN-оптимизация

В FortiClient Endpoint Security Suite реализована такая функция, как WAN-оптимизация. Суть ее заключается в оптимизации использования WAN-соединения, ускоряющее работу различных сетевых приложений. Для этого используется изменение некоторых параметров доступа, а также система кеширования. Стоит отметить, что эта функция работает только в том случае, если доступ к WAN осуществляется через устройство серии FortiGate.

Централизованное управление FortiManager

Программный комплекс FortiClient Endpoint Security Suite, как уже говорилось выше, рассчитан на применение в корпоративных информационных системах. Поэтому в нем реализована возможность централизованного управления всеми политиками безопасности. Для ее реализации используется другой продукт – FortiManager, который позволяет управлять не только программными, но и аппаратно-программными средствами защиты, выпускаемыми Fortinet, Inc.

Система журналирования и отчетности FortiAnalyzer

FortiClient Endpoint Security Suite ведет подробный журнал своей работы, для просмотра которого используется консоль управления. Кроме того, данный продукт может взаимодействовать с другим – FortiAnalyzer. Последний позволяет собирать информацию со всех средств защиты Fortinet, Inc., работающих в сети, и выводить ее в удобном для просмотра и составления отчетности виде.

Оцените статью
Рейтинг автора
5
Материал подготовил
Андрей Измаилов
Наш эксперт
Написано статей
116
Добавить комментарий